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Advanced Management Reporting Database


TOPIC 5 

                     TIPS GETTING STARTED…AN   

                              EXAMPLE REPORT

PURPOSE

The purpose of this topic is to get you started in report designing.  This topic will be an instructor led walkthrough in which you will gain experience in all facets of designing, applying many of the principles that were previously discussed.

OBJECTIVES

At the end of this topic, you will be able to:

· Create a private folder and develop a template for your reporting needs

· Insert databases from the MRDB and perform linking when necessary

· Insert fields, groups and sub totals into a report

· Save the report on the Info Desktop and schedule it

SEGATE DESKTOP
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Before we begin, make sure you are in the desktop as shown above.  If you have the Info Report Designer or one of the viewing tools open, you may close them at this time and if prompted to save, choose NO.
SCENARIO
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The Budget Department has requested a report be developed to assist them.  They inform you that they used to have a STARS report (system prior to MARS) number R455.  This report was a daily allotment file listing grouped by fund.  It lists current allotments, encumbrances, and expenditures by their associated fund. As you listen to this request, you remember the types of questions you need answered in order to proceed.

Scenario Question & Answer

The interview should go something like this:

Is this report a detail or summary report?  Do you need the line number / transaction number detail printed on this report?

No, I will be needing summary information for our Funds.  (Indicates a FCT2 View)

What is the overall purpose of this report?

To provide an Allotment listing by Fund, Agency Class, Agency, and Appropriation that will show us all Encumbrances and Expenditures on a day-to-day basis within the various Funds.

What would you like in the Header?  Objects such as the report title, dates ran, report ID?

We would like the title to be “MARS Project” and then “Allotment File Listing by Fund” underneath.  The report ID should be “R455” and we would like an “As Of Date” in the upper left-hand corner.  If possible, the Fiscal Year in the header would be nice.

What kind of identifying information would you like to appear at the bottom of each page?  Page Number?

Yes, the page number would be great.

Which MARS fields do you need in the body of the report?  You mentioned Agency and Fund.  I need a complete listing of all fields that you would like to report on, from left to right if possible.

We need: FUND, AGENCY CLASS, AGENCY, APPROPRIATION PROGRAM, OBJECT TYPE, ALLOTMENT, PRE-ENCUMBRANCE, ENCUMBRANCE, EXPENDITURE.

Are any of those fields you mentioned calculated, or do they all exist in the system as MARS fields?

No, they are all MARS fields.

How do you want this report grouped in order to keep like information together?  From the purpose statement you gave, I’m guessing that you would like the Fund field to be grouped together.  Any others?

Yes, we would like FUND, AGENCY CLASS, AGENCY, APPROPRIATION, ALLOTMENT and OBJECT TYPE to be grouped.

Any sub-totals, grand totals?

Yes, we would like sub-totals on our amount fields for AGENCY, AGENCY CLASS and FUND.  We would also like a grand total on our amount fields at the end of the report.

Would you like to exclude any of the records or do you want the complete listing?

The complete listing.

info desktop
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new item dialog box
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Creating a Private Folder

We now have plenty of information for the development of this Seagate report.  You will be working with this individual that requested the report throughout its design stage.  You will be able to show them the progress of your work so they can provide feedback until the finished product is approved.  It is always a good idea to do all your development work in a private folder.  This way, the report won’t become public until it has been completed and checked for accuracy.

Step 1
On the Info Desktop window, right-click on the MRDB(2) folder and select New from the available choices.

Step 2
On the New Item dialog box, select Folder and click the <OK>button.

FOLDER dialog box
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Step 3
On the General tab. Type in a title and description for your folder like the example above.

Step 4
Make sure the <Private Folder> radio button is selected and click the <OK> button.

Step 5
Click on the <Yes> button when prompted with the warning message.
warning dialog box
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info desktop
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Creating a Report Template

You should now have a private folder (no hand holding the folder indicating that it is private) beneath the MRDB (2) public folder.  We will be doing the remainder of our design work from this folder.

Now we will complete the steps necessary to design a report template. We will be using the Reporting Wizard that comes standard with the Info Report Designer just to get started.  We will then be doing the rest of our work from the Info Report Designer main screen.  The following steps should be taken to design this report template.

welcome window
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Starting a New Report

Let’s begin by opening the Wizard to start our new report.

Step 1
Highlight the private folder you just created and click on the toolbar icon for the info report designer.

Step 2
On the Welcome screen, select Using the Report Expert.

[image: image49.wmf]REPORT gallery

Step 3
On the Report Gallery window, select Standard and click the <OK> button.

Step 4
On the Data tab, choose Database.

Data explorer
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Step 5
On the Data Explorer window, open the ODBC folder by clicking the + icon.

Step 6
Double click on the MREPP1 database.  The Oracle logon window opens.
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Oracle Log on window

Step 7
On the Oracle Log On window, type your Oracle User Id and Password.

Step 8
Click the <OK> button.  The Data Explorer window opens.
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Data Explorer

Step 9
On the Data Explorer window, select the table view VW_FCT2_EXPENDITURE.

Step 10
Click the <Add> button.

Step 11
Since this is the only view that we need, click the <CLOSE> button.

Step 12
On the Standard Report Expert window, click the <Next> button.

standard report expert
Standard report expert
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Step 13
On the Fields tab, start selecting the database fields you need and clicking on the <Add> button to place them in the Report Fields window.  Recall, the fields are:  FISCAL_YEAR, FUND, , AGENCY, APPROPRIATION_PROGRAM, ALLOTMENT_PROGRAM, OBJECT_TYPE, PRE-ENCUMBRANCE, ENCUMBRANCE, and EXPENDITURE.

Step 14
Once you are finished adding the needed fields, click on the <Design Report >button.

We could actually complete all the requirements of the report from this Wizard.  Instead, we will finish the remainder of the report design from the main window of the design tool.

SUMMARY INFO
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Saving a Report 

Throughout the design process, you should always save your report after each significant change.  That way, in the event of a power failure or other distraction, the majority of your work will be saved.  The next few pages will take you through the process of saving your report in Seagate.

Document properties
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Step 15
On the Menu Bar, select File: Summary Info.

Step 16
On the Document Properties window.  Select the Summary tab.

Step 17
In the AUTHOR field.  Enter your full name.

Step 18
In the TITLE field.  Enter your last name.

Step 19
Click the <OK> button.

These steps will ensure that the Report Object will appear on the Info Desktop with the TITLE and AUTHOR properties filled in.
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Seagate Crystal Reports

Saving Your Report

Step 20
Select the Design tab.

Step 21
On the Menu Bar, select File: Save As: Save On Info APS As.
Step 22
Highlight the folder in which you wish to save the report.

Step 23
Click the <OK> button.

It is absolutely critical that when you initially save your report, you write down two pieces of information:

1. The name that you saved it under

2. The path on the network where it is saved

REPORT TEMPLATE
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Organizing Our Window

You should now be in the Info Report Designer with the MRDB view and fields already inserted.  Let’s take a few minutes to organize our workspace by increasing the size of our Headers/Footers.

We will be using the Page Header for our title, fiscal year, date and field labels.  Let’s increase the size of this window by left-clicking and hold the cursor where the dividing line is at the bottom of the Page Header section.  Your cursor will look like two lines with arrows in each direction, up and down.  Drag your mouse down until the Page Header window takes up one-third of the window space and release your mouse button. Now you will have to drag each field label back down so it rests at the top of that dividing line.  The screen shot on the following page shows these changes.  As a shortcut, you may click on each field using your <SHIFT> key and drag the entire row down all at once.  You may also Drag a box around all of the Field Labels and drag them down at one time.

Inserting Special Fields

Let’s now take a few minutes to insert any special fields that the user may need.  From our interview, we discovered that they would like an “As Of” run date field put in.   The next few pages will take you through this process.

Step 1
Select the Design tab.

Step 2
On the Menu Bar,  select Insert: Field Object.
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INSERTING SPECIAL FIELDS 

Step 3
On the Field Explorer window, select Print Date from the Special fields options.
Step 4
Drag the special field to the desired location in the report.

Now repeat these steps for the Modification Date and Total Page Count special fields and place these on your report. The screen shot on the following page shows you what it should look like.

Step 6
Click  the <Close> button on the Insert Fields Dialog Box.

Some of these special fields may already be inserted into your report.  Seagate will assume you want a few default fields whenever you begin a new report.  You may delete any duplicate special fields by right-clicking on the field to be deleted and select Delete from the available choices.
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INSERTING SPECIAL FIELDS

Inserting Text Objects

From our interview, we learned that the title should be MARS Project and the report title is Expenditure Listing by Fund.  We also learned that the report ID is R455.  Let’s go ahead and enter these text objects into our report template.  The following pages will take us through the process.

INSERTING TEXT OBJECTS
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Step 1
Select the Design tab.

Step 2
On the Menu Bar, select Insert: Text Object.
Step 3
Drag the text box to the top center section of the Page Header and click your mouse button.

Step 4
In the Text Box.   Type MARS Project then and adjust the width and length by dragging the corners of the text box.

INSERTING TEXT OBJECTS
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Text object
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Step 5
Now repeat the steps for the report ID and the report title.  Use the screen shot on the previous page as your guide.

Remember during the interview that the user stated that they would like to have an “As Of” date and time.  We have already inserted those two special fields but did not enter a text object that says “As Of” to the report.  Go ahead and add this text object and put it before those two special fields.  Again, use the picture on the previous page as your guide.

The only other item they wanted in the Header is the field for Fiscal Year.  We already have that field in our Details section.  We will now move this field into the header.

MOVING FIELDS
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design view
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Moving Fields

Step 1
Right-click on the data label field for FISCAL YEAR, not the actual field in the Details section of the report.  Select Delete from the available choices.

Step 2
Now left-click and hold the data field for FISCAL YEAR and drag it into the Header and place it underneath the PRINT DATE and PRINT TIME fields.

Refer to the previous screen shots as a guide for these two steps.

MOVING FIELDS
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Step 3
Now go ahead and insert a text object in front of the FISCAL YEAR field that reads FY: as this will aid in identifying this field.

This completes our Header information, we will now insert our groups into the report.

Select the preview icon to view your report.

INSERTING GROUPS
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From our interview session, we learned that there will be six groups: FUND, AGENCY, APPROPRIATION PROGRAM, ALLOTMENT PROGRAM and OBJECT TYPE.

Step 1
On the Menu Bar, select Insert: Group.


INSERT GROUP dialog box
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design view
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Step 2
On the Insert Group dialog box, select the first field to be grouped:  VW_FCT2_EXPENDITURE.FUND from the first drop-down box.  The second drop-down box should be set for ascending order.

Step 3
Click the<OK> button.  Notice that you now have a group header for this group as well as a group name that has been inserted.

Step 4
Repeat these steps for the other six groups.

When you are finished, go ahead and delete the Group Name fields that the system placed in the Group Header section.  Just right-click on each one and select Delete from the available choices.  You will want to use these Group Name fields for identifying purposes. For our example, it will be obvious what our groups will be, so we don’t need to display them.

INSERTING GROUPS
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Inserting Sub-Totals

We also learned from our interview that we have to insert subtotals for all the amount fields for the following groups: Agencyand Fund.  They would also like a Grand Total to appear at the end of the report for these amount fields.  The next few pages will take you through this process.

Insert subtotals
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insert subtotal dialog box
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Inserting Sub Totals

Step 1
Right-click on the ALLOTMENT field in the Details section of your report.  Select Insert Subtotal from the available list.


Step 2
On the Insert Subtotal dialog box, select the group from the AGENCY field which should be Group # 3.
Step 3
Click the <OK> buton.

Subtotal fields
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Now repeat these steps for the other amount fields (Pre-Encumbrance, Encumbrance and Expenditure) for Group # 3.  The screen shot above shows the finished result.

After you are finished, we need to insert the other two subtotals, one for AGENCY CLASS and FUND.  First, you will need to right-click on the first amount field (Allotment) in the Details section and select Insert Subtotal.  Then you will have to select Group # 2 for AGENCY CLASS and click the <OK> button.  Repeat these steps for the other amount fields.

Finally, repeat all steps for the final subtotal, which is FUND.  The screen shot below shows the report after all subtotals have been entered.

INSERTING SUBTOTALS
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Inserting Grand Totals

Now that we have all our requirements met for the Subtotals in the report, we can now insert a Grand Total field for each of our amount fields.  Grand Totals will be printed once, at the very end of the report.  Where the Subtotal may give the total expenditures of a given Fund, the Grand Total will give total expenditures for ALL Funds.

The next few pages will take you through the process of inserting a GRAND TOTAL field.

INSERTING GRAND TOTALS
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Step 1
Start by right-clicking on the amount field for ALLOTMENT.

Step 2
Select Insert Grand Total from the available choices.

Grand totals dialog box
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design view
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Step 3
In the Insert Grand Total dialog box, select sum from the drop-down box.

Step 4
Click the <OK> button.

You should now see a Grand Total field for Allotments in your report.  The screen shot above shows the resulting field.  Go ahead and repeat this process for the other amount fields (Pre-encumbrance, Encumbrance and Expenditure).
Amount fields
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Refreshing Your Report

The screen shot above shows the result of inserting Grand Totals for each of our amount fields.

Save your report.

In a previous section we demonstrated the Refresh option in the Info Report Designer.  This will become one of your most valuable resources when designing a report.  It allows you to view your printed report at any stage of the development process.  That way, you can see the results of adding a field or group to make sure it provides the intended result.  Since we have added a lot of information into our report, we should go ahead and refresh it at this point to see what it looks like.  The following pages will take you through this process.

REFRESHING YOUR REPORT
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server log on dialog box
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Step 1
On the Design tab, click on the Refresh [image: image31.bmp] button in the Toolbar.

Step 2
On the Oracle SQL dialog box.  Enter your Oracle User ID, Password and mrepp1 for the Server.

Step 3
Click the <OK> button.

After the request is finished processing on the server, you should see the results of your report from the Preview tab.  We will now discuss various options for formatting.

Preview tab
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The previous page shows the result of refreshing our report.  Take a look at the three highlighted areas.

3. Our data field labels are being cut off.  One of the easiest solutions for this is to reduce the font size and/or increase the size of the text object by highlighting and dragging the text box to increase its size.

4. Too much white space in between our fields.  This causes the report to be longer than it should.  It also makes the report look unprofessional and difficult to read.  We will fix this by hiding sections of our report.

5. Our amount fields are also being cut off.  We need to decrease the font size and/or increase the size of the field by highlighting and dragging.

Let’s go ahead and make these changes to our report.  You have the option to format from both the Design tab and the Preview tab.  We will look at both ways.

Changing font size
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Let’s tackle the data labels first.

Step 1
On the Preview tab, click on the first data label (should be Fund), hold down your <SHIFT> key and continue to select the rest of these data labels.

Step 2
Once they are selected, go to your formatting toolbar and click on the drop-down box for the font size.

Step 3
Select 8 or manually type in 7 for the font size.

Screen shot
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Step 4
On the Design tab, click on the Zoom drop-down box [image: image35.bmp] and increase the size of your report.

Step 5
Highlight the Fund data label and drag the box by holding your left-click button on your mouse on one of the corners of the text object.

Refer to the screen shot above for a model as to what your results should look like.

FORMATTING YOUR REPORT
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Did you notice all that white space in your report?  Here is how we will make better use of our space.  Since we are not using Group Header labels in our report, we can hide these sections so they won’t be printed.

Step 1
On the Design tab, right-click on the Group Header #1 section (the grey area) and select Hide (Drill Down OK) from the available choices.

Repeat this step for Group Header # 2 thru Group Header# 6.  You can also do this step for Group Footer # 4 thru Group Footer # 6.  When finished, you should notice that these sections are now greyed out.  When this report prints, these sections will be suppressed, and a lot of our white space will be eliminated.  Go ahead and click on your Preview tab when finished.

Page header
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You can see from the above screen shot that our report is starting to look professional.   Let’s go ahead and perform the same steps to our data fields as we did for our data labels.

The fields you should focus on are the fields that are being cut off, mainly the amount fields.  The next few pages will take you through this process.

Preview tab
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Step 1
On the Preview tab, highlight the top row of data fields and adjust the font size  and/or justification (centering) like we did in the previous example.  If you make a mistake, you can always use the Undo command [image: image39.bmp].

Zoom view
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Step 2
Zoom if necessary.

Step 3
Highlight one of your amount fields and increase the width so even large values will be able to fit.  Repeat this for all of your fields that need it.

Tip:  
Amount fields should be set for right justification while the other fields can be centered.

Subtotals and grand totals
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Step 4
On the Design tab, adjust the size and position of the Subtotals and Grand Totals.  Keep flipping back and forth between the Preview and the Design tab so you can check your work as you go.

This process usually requires you to spend some time formatting all of your fields and labels.  Once you are comfortable with the way it looks in the Preview tab, you are ready to insert your Subtotal and Grand Total text labels.

Added subtotals and grand total
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FINISHED PRODUCT
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Refer to the screen shot above.  

Go ahead and insert a text object for each Subtotal and Grand Total field within your report, from the Design tab.  That way, a user will clearly know what that total represents.  When you’re finished, click on the Preview tab to see how it looks.  The Info Report Designer allows you to format the report in many ways.  

This process takes time to learn.  The screen shot on the previous page shows this report with some extra add-ons included.  A line was entered to give it more form and all fields have been adjusted for length and width.  

REPORT PROPERTIES
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Refreshing Your Report

Whenever you design a report or make edits to an existing report, you must always refresh the report object before you attempt to schedule it.  This is done from the Info Desktop screen.

Step 1
Right-click on your report in your private folder that you created.

Step 2
Select Properties from the available choices.

Step 3
On the Report Properties dialog box, click on the Refresh button.

Step 4
Click the <OK> button.

This step is to ensure that the latest version of your report reflects what is saved out on the server.  Any time you make changes to one of your reports, you must perform this step before scheduling.  We will cover that next.

SCHEDULING YOUR REPORT
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Scheduling Your Report

Step 1
Right-click on your report object and select Schedule from the available choices.

You should already know how to schedule reports from the Introductory Management Reporting Database class.  If you need refreshing, look over that topic from the manual used for that course.  We are assuming you are already comfortable with this process for this class.

SCHEDULING YOUR REPORT
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Step 2 
On the LogOn tab, enter your User Name and Password for Oracle.

Step 3
Click the <Schedule> button.

You can expand your report object at this time and watch as the APS attempts to 

schedule it.

VIEWING THE INSTANCE FROM YOUR REPORT
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Viewing Your Instance

If your report creates a successful instance, go ahead and open it up using one of your viewing tools, the Info Analyzer or the Info Viewer.  This is exactly how the report will look to the users who will be accessing it.  Spend a few minutes viewing different pages of your report in order to see how the Groups and Subtotals that you entered affect the report.  Jump to the last page of the report in order to see the Grand Total fields.

From here, you would probably open the report back up in the Info Report Designer and make further revisions to the way it looks.  In most cases, it is a trial and error process.  You could show the report to the user who requested it and get their feedback as to any further changes that need to be done.  

Step 4
Click the bottom ‘X’ in the upper right hand corner.  


In this topic we have learned how to:

· Create a private folder and develop a template for your reporting needs

· Insert databases from the MRDB and perform linking when necessary

· Insert fields, groups and sub totals into a report

· Save the report on the Info Desktop and schedule it
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Are there any questions concerning the information covered in this topic?
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Delete those Group Name fields.
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Right-click on the Group Header #1





Increase the size of text box





Highlight and Drag





Easier to work if you zoom 
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